Dynamic DNS Update Script for dynuDNS MikroTik الدخول على المايكروتيك من الخارج



وعدتكم فى الدرس الماضى بعد التعرف على موقع تثبيت الايبى المجانى

الموقع القوى جدا فى مجال الدعم والعمل وكل خدماته مجانية..

Dynu Systems

لمن لم يتعرف على الموقع بدلا من اعادة شرحه تفضل بزيارة الموضوع التالى..

الملفات المرفقة

اترك رد ليكتمل التحميل من فضلك سيرفر ميكروتيك العرب

الدرس الحجم , عدد مرات التحميل :

الان فى درس اليوم اعددت اسكريبت جاهز يقوم بدوره اوتوماتيكى فى السيرفر مايكروتيك..

مهمته هى البحث عن الايبى اللى السيرفر شغال عليه ويعمل له ابديت فورا على الموقع..

وانت استفادتك انك هاتثبت اسم للشبكة تفتحها من اى مكان بالعالم..

تفتح سيرفر التوزيع او الدمج من اى مكان وفى اى وقت..

مش هاتضطر تشترى ستاتيك ايبى من اى شركة انترنت بتكلفة

مش هاتضطر تشترى من مواقع تثبيت ايبى اشتراكات باهظة بالدولار

كمان نتفادى مشكلة الاستاتيك ايبى من الشركة

لان الاستاتيك ايبى له عيوب خطيرة..

عيوب الاستاتيك ايبى فى الشبكات..

(1) لو عميل خد بلوك من موقع او منتدى معين كل الشبكة بتاخد البلوك..

(2) لو عميل خد بلوك من فيس بوك ايضا نفس المشكلة..

(3) التتبع الامنى..

العديد من المشكلات بسبب توحيد الايبى مدى الحياة بالاستاتيك ايبى..

لكن فكرة الاسكريبت هى ان روترك بياخد ايبهات مختلفة دوما ولكن الموقع يقوم بمراسلتك

بالايبى الجديد ومجانا

قمت بعمل اسكريبتات مجانا لكم نسخة 6 ونسخة 5 ونسخة 3.30

شاهد بالفيديو الطريقة للتركيب داخل السيرفر..


حمل الملفات الخاصة بالاسكريبت مجانا..

الملفات المرفقة

اترك رد ليكتمل التحميل من فضلك سيرفر ميكروتيك العرب

mikrotik v5 الحجم , عدد مرات التحميل :

الملفات المرفقة

اترك رد ليكتمل التحميل من فضلك سيرفر ميكروتيك العرب

mikrotik v6 الحجم , عدد مرات التحميل :
Dynamic DNS Update Script for dynuDNS MikroTik

dynuDNS Update Script - MikroTik RouterOS

Dynu Systems

Dynamic DNS Update Script for dynuDNS MikroTik الدخول على المايكروتيك من الخارج


  1. مشكووووووووووووووووووووووووووووور

    ردحذف
  2. مش بيشتغل علي دمج PPPC بدخول علي الروتر علي طول

    ردحذف
  3. الرول مش بينزل فى النيوترمنال بعد ما بعمل بست وادوس انتر مرتين بروح للاسكربت مش بلاقى فيها حاجه بينزل بس فى اسكدول فقط ارجوا الحل

    ردحذف
  4. وانا زى استاذ محمود جمال مش بلاقى حاجه نزلت وبلاقى علامه / عليها خطأ تقريبا

    ردحذف
  5. السلام عليكم
    ياريت حصرتك تحل مشكله الاسكربت بتاع فرجن 6
    او تشيله

    ردحذف
  6. انا حاولت اعالج الرول بقى بينزل فى الاسكربت بس للاسف لما بدوس رن اسكربت مش بينفز حاجه بردو ارجوا الحل

    ردحذف
  7. /system script
    add name=Dynu policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive source="\n:global ddnsuser \"mego207\"\r\
    \n:global ddnspass \"**********\"\r\
    \n:global theinterface \"**********\"\r\
    \n:global ddnshost \"**********\"\r\
    \n:global ipddns [:resolve \$ddnshost];\r\
    \n:global ipfresh [ /ip address get [/ip address find interface=\$theinterfa\ ce ] address ]\r\
    \n:if ([ :typeof \$ipfresh ] = nil ) do={\r\
    \n:log info (\"dynu: No ip address on \$theinterface .\")\r\
    \n} else={\r\
    \n:for i from=( [:len \$ipfresh] - 1) to=0 do={\r\
    \n:if ( [:pick \$ipfresh \$i] = \"/\") do={\r\
    \n:set ipfresh [:pick \$ipfresh 0 \$i];\r\
    \n}\r\
    \n}\r\
    \n:if (\$ipddns != \$ipfresh) do={\r\
    \n:log info (\"dynu: IP-dynu = \$ipddns\")\r\
    \n:log info (\"dynu: IP-Fresh = \$ipfresh\")\r\
    \n:log info \"dynu: Update IP needed, Sending UPDATE...!\"\r\
    \n:global str \"/nic/update\?hostname=\$ddnshost&myip=\$ipfresh\"\r\
    \n/tool fetch address=api.dynu.com src-path=\$str mode=http user=\$ddnsuser \\\\r\
    \npassword=\$ddnspass dst-path=(\"/Dynu.\".\$ddnshost)\r\
    \n:delay 1\r\
    \n:global str [/file find name=\"Dynu.\$ddnshost\"];\r\
    \n/file remove \$str\r\
    \n:global ipddns \$ipfresh\r\
    \n:log info \"dynu: IP updated to \$ipfresh!\"\r\
    \n} else={\r\
    \n:log info \"dynu: dont need changes\";\r\
    \n}\r\
    \n}"

    ردحذف
  8. نفس المشكله عندى نسخة 5.18 الرول مش بينزل بيدى خظاء فى النيوترمنال بعد ما بعمل بست وادوس انتر مرتين بروح للاسكربت مش بلاقى

    ردحذف
  9. الاسكريبت مش بينزل معايا
    روتر بورد RB433UAH نسخه 5.26

    ردحذف
  10. مشكور اخي الله يحفظك

    ردحذف
  11. ياجماعه انا عملت كل شي ولمن اعمل رن اسكربت مايعملش حاجه في اللوج ايه المشكله

    ردحذف
  12. شكرررررررررررررررا

    ردحذف
  13. مش شغال معايا ممكن حد ينورنا

    ردحذف
  14. شادى بعمل الحاجه نقصه عشان ترجعلو تاني

    ردحذف
  15. شكرا لك استذ شادي للشروحاتك الجيدة

    ردحذف
  16. بيحدث رقم ايبى دخول السرفر مش ايبى الشركة

    ردحذف
  17. ياجماعة الطريق دى لو انت عامل الروترات بريدج لكن غير كدة مش هتشتغل

    ردحذف
  18. رائع ممتاز وشكرا لحضرتك أ شادي

    ردحذف

إذا أعجبك محتوى موقع ميكروتيك العرب اتمنى البقاء على تواصل دائم ، فقط قم بإدخال بريدك الإلكتروني للإشتراك في بريد المدونة السريع ليصلك جديد المدونة أولاً بأول ، كما يمكنك إرسال رساله بالضغط على الزر المجاور ...