فصل التصفح عن الداونلود التحميل بطريقة احترافية مايكروتيك سيرفر mikrotik download & brow



من اروع موضوعات المايكروتيك

والذى يعمل بكفاءة عالية جدا حتى الان

طريقة لفصل التصفح عن التحميل عبر الفايروول من الميكروتيك

شاهد الفيديو






الاسكريبت كاملا للتحميل 


/ip firewall layer7-protocol
add name="Extension \" .exe \"" regexp="^.get.+\\.exe.\$"
add name="Extension \" .rar \"" regexp="^.get.+\\.rar.\$"
add name="Extension \" .zip \"" regexp="^.get.+\\.zip.\$"
add name="Extension \" .7z \"" regexp="^.get.+\\.7z.\$"
add name="Extension \" .cab \"" regexp="^.get.+\\.cab.\$"
add name="Extension \" .asf \"" regexp="^.get.+\\.asf.\$"
add name="Extension \" .mov \"" regexp="^.get.+\\.mov.\$"
add name="Extension \" .wmv \"" regexp="^.get.+\\.wmv.\$"
add name="Extension \" .mpg \"" regexp="^.get.+\\.mpg.\$"
add name="Extension \" .mpeg \"" regexp="^.get.+\\.mpeg.\$"
add name="Extension \" .mkv \"" regexp="^.get.+\\.mkv.\$"
add name="Extension \" .avi \"" regexp="^.get.+\\.avi.\$"
add name="Extension \" .flv \"" regexp="^.get.+\\.flv.\$"
add name="youtube Download" regexp=videoplayback
add name="Extension \" .pdf \"" regexp="^.get.+\\.pdf.\$"
add name="Extension \" .wav \"" regexp="^.get.+\\.wav.\$"
add name="Extension \" .wma \"" regexp="^.get.+\\.wma.\$"
add name="Extension \" .rm \"" regexp="^.get.+\\.rm.\$"
add name="Extension \" .mp3 \"" regexp="^.get.+\\.mp3.\$"
add name="Extension \" .mp4 \"" regexp="^.get.+\\.mp4.\$"
add name="Extension \" .ram \"" regexp="^.get.+\\.ram.\$"
add name="Extension \" .rmvb \"" regexp="^.get.+\\.rmvb.\$"
add name="Extension \" .dat \"" regexp="^.get.+\\.dat.\$"
add name="Extension \" .daa \"" regexp="^.get.+\\.daa.\$"
add name="Extension \" .iso \"" regexp="^.get.+\\.iso.\$"
add name="Extension \" .nrg \"" regexp="^.get.+\\.nrg.\$"
add name="Extension \" .bin \"" regexp="^.get.+\\.bin.\$"
add name="Extension \" .vcd \"" regexp="^.get.+\\.vcd.\$"
add name="shady Download" regexp=videoplayback
/ip firewall mangle
add action=mark-connection chain=prerouting comment="7z DOWNS" disabled=no \
    layer7-protocol="Extension \" .7z \"" new-connection-mark="7z DOWNS" \
    passthrough=yes protocol=tcp
add action=mark-packet chain=postrouting connection-mark="7z DOWNS" disabled=no \
    new-packet-mark=7z passthrough=no protocol=tcp
add action=mark-connection chain=prerouting comment="asf DOWNS" disabled=no \
    layer7-protocol="Extension \" .asf \"" new-connection-mark="asf DOWNS" \
    passthrough=yes protocol=tcp
add action=mark-packet chain=postrouting connection-mark="asf DOWNS" disabled=\
    no new-packet-mark=asf passthrough=no protocol=tcp
add action=mark-connection chain=prerouting comment="avi DOWNS" disabled=no \
    layer7-protocol="Extension \" .avi \"" new-connection-mark="avi DOWNS" \
    passthrough=yes protocol=tcp
add action=mark-packet chain=postrouting connection-mark="avi DOWNS" disabled=\
    no new-packet-mark=avi passthrough=no protocol=tcp
add action=mark-connection chain=prerouting comment="bin DOWNS" disabled=no \
    layer7-protocol="Extension \" .bin \"" new-connection-mark="bin DOWNS" \
    passthrough=yes protocol=tcp
add action=mark-packet chain=postrouting connection-mark="bin DOWNS" disabled=\
    no new-packet-mark=bin passthrough=no protocol=tcp
add action=mark-connection chain=prerouting comment="flv DOWNS" disabled=no \
    layer7-protocol="Extension \" .flv \"" new-connection-mark="flv DOWNS" \
    passthrough=yes protocol=tcp
add action=mark-packet chain=postrouting connection-mark="flv DOWNS" disabled=\
    no new-packet-mark=flv passthrough=no protocol=tcp
add action=mark-connection chain=prerouting comment="iso DOWNS" disabled=no \
    layer7-protocol="Extension \" .iso \"" new-connection-mark="iso DOWNS" \
    passthrough=yes protocol=tcp
add action=mark-packet chain=postrouting connection-mark="iso DOWNS" disabled=\
    no new-packet-mark=iso passthrough=no protocol=tcp
add action=mark-connection chain=prerouting comment="mkv DOWNS" disabled=no \
    layer7-protocol="Extension \" .mkv \"" new-connection-mark="mkv DOWNS" \
    passthrough=yes protocol=tcp
add action=mark-packet chain=postrouting connection-mark="mkv DOWNS" disabled=\
    no new-packet-mark=mkv passthrough=no protocol=tcp
add action=mark-connection chain=prerouting comment="exe DOWNS" disabled=no \
    layer7-protocol="Extension \" .exe \"" new-connection-mark="exe DOWNS" \
    passthrough=yes protocol=tcp
add action=mark-packet chain=postrouting connection-mark="exe DOWNS" disabled=\
    no new-packet-mark=exe passthrough=no protocol=tcp
add action=mark-connection chain=prerouting comment="mov DOWNS" disabled=no \
    layer7-protocol="Extension \" .mov \"" new-connection-mark="mov DOWNS" \
    passthrough=yes protocol=tcp
add action=mark-packet chain=postrouting connection-mark="mov DOWNS" disabled=\
    no new-packet-mark=mov passthrough=no protocol=tcp
add action=mark-connection chain=prerouting comment="mp3 DOWNS" disabled=no \
    layer7-protocol="Extension \" .mp3 \"" new-connection-mark="mp3 DOWNS" \
    passthrough=yes protocol=tcp
add action=mark-packet chain=postrouting connection-mark="mp3 DOWNS" disabled=\
    no new-packet-mark=mp3 passthrough=no protocol=tcp
add action=mark-connection chain=prerouting comment="mp4 DOWNS" disabled=no \
    layer7-protocol="Extension \" .mp4 \"" new-connection-mark="mp4 DOWNS" \
    passthrough=yes protocol=tcp
add action=mark-packet chain=postrouting connection-mark="mp4 DOWNS" disabled=\
    no new-packet-mark=mp4 passthrough=no protocol=tcp
add action=mark-connection chain=prerouting comment="mpeg DOWNS" disabled=no \
    layer7-protocol="Extension \" .mpeg \"" new-connection-mark="mpeg DOWNS" \
    passthrough=yes protocol=tcp
add action=mark-packet chain=postrouting connection-mark="mpeg DOWNS" disabled=\
    no new-packet-mark=mpeg passthrough=no protocol=tcp
add action=mark-connection chain=prerouting comment="mpg DOWNS" disabled=no \
    layer7-protocol="Extension \" .mpg \"" new-connection-mark="mpg DOWNS" \
    passthrough=yes protocol=tcp
add action=mark-packet chain=postrouting connection-mark="mpg DOWNS" disabled=\
    no new-packet-mark=mpg passthrough=no protocol=tcp
add action=mark-connection chain=prerouting comment="nrg DOWNS" disabled=no \
    layer7-protocol="Extension \" .nrg \"" new-connection-mark="nrg DOWNS" \
    passthrough=yes protocol=tcp
add action=mark-packet chain=postrouting connection-mark="nrg DOWNS" disabled=\
    no new-packet-mark=nrg passthrough=no protocol=tcp
add action=mark-connection chain=prerouting comment="pdf DOWNS" disabled=no \
    layer7-protocol="Extension \" .pdf \"" new-connection-mark="pdf DOWNS" \
    passthrough=yes protocol=tcp
add action=mark-packet chain=postrouting connection-mark="pdf DOWNS" disabled=\
    no new-packet-mark=pdf passthrough=no protocol=tcp
add action=mark-connection chain=prerouting comment="ram DOWNS" disabled=no \
    layer7-protocol="Extension \" .ram \"" new-connection-mark="ram DOWNS" \
    passthrough=yes protocol=tcp
add action=mark-packet chain=postrouting connection-mark="ram DOWNS" disabled=\
    no new-packet-mark=ram passthrough=no protocol=tcp
add action=mark-connection chain=prerouting comment="rar DOWNS" disabled=no \
    layer7-protocol="Extension \" .rar \"" new-connection-mark="rar DOWNS" \
    passthrough=yes protocol=tcp
add action=mark-packet chain=postrouting connection-mark="rar DOWNS" disabled=\
    no new-packet-mark=rar passthrough=no protocol=tcp
add action=mark-connection chain=prerouting comment="rm DOWNS" disabled=no \
    layer7-protocol="Extension \" .rm \"" new-connection-mark="rm DOWNS" \
    passthrough=yes protocol=tcp
add action=mark-packet chain=postrouting connection-mark="rm DOWNS" disabled=no \
    new-packet-mark=rm passthrough=no protocol=tcp
add action=mark-connection chain=prerouting comment="rmvb DOWNS" disabled=no \
    layer7-protocol="Extension \" .rmvb \"" new-connection-mark="rmvb DOWNS" \
    passthrough=yes protocol=tcp
add action=mark-packet chain=postrouting connection-mark="rmvb DOWNS" disabled=\
    no new-packet-mark=rmvb passthrough=no protocol=tcp
add action=mark-connection chain=prerouting comment="wav DOWNS" disabled=no \
    layer7-protocol="Extension \" .wav \"" new-connection-mark="wav DOWNS" \
    passthrough=yes protocol=tcp
add action=mark-packet chain=postrouting connection-mark="wav DOWNS" disabled=\
    no new-packet-mark=wav passthrough=no protocol=tcp
add action=mark-connection chain=prerouting comment="wma DOWNS" disabled=no \
    layer7-protocol="Extension \" .wma \"" new-connection-mark="wma DOWNS" \
    passthrough=yes protocol=tcp
add action=mark-packet chain=postrouting connection-mark="wma DOWNS" disabled=\
    no new-packet-mark=wma passthrough=no protocol=tcp
add action=mark-connection chain=prerouting comment="wmv DOWNS" disabled=no \
    layer7-protocol="Extension \" .wmv \"" new-connection-mark="wmv DOWNS" \
    passthrough=yes protocol=tcp
add action=mark-packet chain=postrouting connection-mark="wmv DOWNS" disabled=\
    no new-packet-mark=wmv passthrough=no protocol=tcp
add action=mark-connection chain=prerouting comment="zip DOWNS" disabled=no \
    layer7-protocol="Extension \" .zip \"" new-connection-mark="zip DOWNS" \
    passthrough=yes protocol=tcp
add action=mark-packet chain=postrouting connection-mark="zip DOWNS" disabled=\
    no new-packet-mark=zip passthrough=no protocol=tcp
add action=mark-connection chain=prerouting comment="daa DOWNS" disabled=no \
    layer7-protocol="Extension \" .daa \"" new-connection-mark="daa DOWNS" \
    passthrough=yes protocol=tcp
add action=mark-packet chain=postrouting connection-mark="daa DOWNS" disabled=\
    no new-packet-mark=daa passthrough=no protocol=tcp
add action=mark-connection chain=prerouting comment="dat DOWNS" disabled=no \
    layer7-protocol="Extension \" .dat \"" new-connection-mark="dat DOWNS" \
    passthrough=yes protocol=tcp
add action=mark-packet chain=postrouting connection-mark="dat DOWNS" disabled=\
    no new-packet-mark=dat passthrough=no protocol=tcp
add action=mark-connection chain=prerouting comment="vcd DOWNS" disabled=no \
    layer7-protocol="Extension \" .vcd \"" new-connection-mark="vcd DOWNS" \
    passthrough=yes protocol=tcp
add action=mark-packet chain=postrouting connection-mark="vcd DOWNS" disabled=\
    no new-packet-mark=vcd passthrough=no protocol=tcp
add action=mark-connection chain=prerouting comment=YouTube disabled=no \
    layer7-protocol="youtube Download" new-connection-mark="youtube DOWNS" \
    passthrough=yes protocol=tcp
add action=mark-packet chain=postrouting connection-mark="youtube DOWNS" \
    disabled=no new-packet-mark=youtube passthrough=no protocol=tcp
add action=mark-connection chain=prerouting comment=shady disabled=no \
    layer7-protocol="shady Download" new-connection-mark="shady DOWNS" \
    passthrough=yes protocol=tcp src-address-list=www.shady.com
add action=mark-packet chain=postrouting connection-mark="shady DOWNS" \
    disabled=no new-packet-mark=shady passthrough=no protocol=tcp \
    src-address-list=www.shady.com
add action=mark-packet chain=prerouting comment=Ping-Request disabled=no \
    new-packet-mark=ping_requests passthrough=yes protocol=icmp
add action=mark-packet chain=prerouting disabled=no new-packet-mark=all \
    passthrough=no
/queue simple
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=both \
    disabled=no interface=all limit-at=16k/16k max-limit=16k/16k name=p2p p2p=\
    all-p2p parent=none priority=8 queue=hotspot-default/hotspot-default \
    total-queue=default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=both \
    disabled=no interface=all limit-at=16k/16k max-limit=16k/16k name=user-p2p \
    parent=p2p priority=8 queue=hotspot-default/hotspot-default total-queue=\
    default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=both \
    disabled=no interface=all limit-at=1840k/1840k max-limit=1840k/1840k name=\
    Max_Download packet-marks="exe,rar,zip,7z,bin,mp4,wav,pdf,asf,avi,mov,wmv,mp\
    g,mpeg,rm,iso,nrg,daa,vcd,3gp,ram,rmvb,mkv,wma" parent=none priority=8 \
    queue=hotspot-default/hotspot-default total-queue=default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=both \
    disabled=no interface=all limit-at=1840k/1840k max-limit=1840k/1840k name=\
    users-download parent=Max_Download priority=8 queue=\
    hotspot-default/hotspot-default total-queue=default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=both \
    disabled=no interface=all limit-at=1040k/1040k max-limit=1040k/1040k name=\
    videos packet-marks=youtube parent=none priority=8 queue=\
    hotspot-default/hotspot-default total-queue=default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=both \
    disabled=no interface=all limit-at=1040k/1040k max-limit=1040k/1040k name=\
    users-video parent=videos priority=8 queue=hotspot-default/hotspot-default \
    total-queue=default-small



  1. الف شكر على هذا المجهود بس هى الطريقه تنفع على روتر بورد عليه دمج وتوزيع واتمنى انك تشفلنا حل فى تحديد الاستخدام العادل على العملاء للانى جربت الطرق السابقه ولن تنفع والف مليون شكر للكبير قوى شادى

    ردحذف
    الردود
    1. جارى العمل على افكار جديدة للموضوع باذن الله..والطريقة تنفع تمام على الدمج + التوزيع

      حذف
    2. الف شكر على الرد وربنا يخليك لينا وميحرمنش منك

      حذف
  2. طيب لو انا عيز اعمل خط تصفح وخط دون لود الحل

    ردحذف
    الردود
    1. http://mikrotikarabic.blogspot.com/2014/02/12-8-browse-internet-line-and-line.html

      حذف
  3. حضرتك انا اول مرة ادخل الموقع الجميل ده وكان عندى طلب انا باختصار عندى شبكة صغيرة مع جيرانى معايا حوالى 12 او 13 مشتركين انا شغال مع لينك دي اس ال خط 2 ميجا وكنت 4 ميجا من ششهر والمشكلة انى مش عارف اقسم الاستخدام لكل مشترك عشان الباقه بتخلص وبخسر فلوس وبصراحه انا معنديش خبرة خالص فى طريقه تحديد المساحة لكل واحد فهتعبك معايا ارجو الرد وشكرا لحضرتك اخوك بهاء

    ردحذف
  4. انا عملت اللي في الفيديو بالظبط بسي للاسف التحميل ساحب السرعه كلها انا عندي كيسة عليها سيرفر ميكروتك نسخه 5.20

    ردحذف
    الردود
    1. أنا أيضآ نفس المشكلة قللت السرعه لليوتيوب والتحميل لسرعه 128 لكن التحميل واليوتيوب بيسحب السرعه كلها

      حذف
    2. ياريت حد يرد علينا المشكلة ع الكل

      حذف
  5. نفس المشكله انا عملت اللي في الفيديو بالظبط بسي للاسف التحميل ساحب السرعه كلها انا عندي كيسة عليها سيرفر ميكروتك نسخه 5.18

    ردحذف
  6. ياريت استاذ شادي يرد

    ردحذف
  7. يا ريت يا استاذ شادي يعمل شرح لعمل هط للتحمل وخط للتصفح

    ردحذف
  8. كنت عملها بس لما شفت الردود وقفت
    وياريت فيه حاجة حلو

    ردحذف
  9. يا جماعة الطريقة دي شغالة حلو قوي قبل التزميز الجديد https .. لازم تشوفلنا يا باشمهندس شادي حل لتحكم في التزميز ده

    ردحذف
  10. يريت تعلموني ازاي اسحب الرول مش عارف اسحبه كتيكست فايل ....ربنا يرزقكم

    ردحذف
  11. أزال المؤلف هذا التعليق.

    ردحذف
  12. السلام عليكم
    في مشكلة في السكربت الاخير

    /queue simple
    add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=both \
    disabled=no interface=all limit-at=16k/16k max-limit=16k/16k name=p2p p2p=\
    all-p2p parent=none priority=8 queue=hotspot-default/hotspot-default \
    total-queue=default-small
    add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=both \
    disabled=no interface=all limit-at=16k/16k max-limit=16k/16k name=user-p2p \
    parent=p2p priority=8 queue=hotspot-default/hotspot-default total-queue=\
    default-small
    add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=both \
    disabled=no interface=all limit-at=1840k/1840k max-limit=1840k/1840k name=\
    Max_Download packet-marks="exe,rar,zip,7z,bin,mp4,wav,pdf,asf,avi,mov,wmv,mp\
    g,mpeg,rm,iso,nrg,daa,vcd,3gp,ram,rmvb,mkv,wma" parent=none priority=8 \
    queue=hotspot-default/hotspot-default total-queue=default-small
    add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=both \
    disabled=no interface=all limit-at=1840k/1840k max-limit=1840k/1840k name=\
    users-download parent=Max_Download priority=8 queue=\
    hotspot-default/hotspot-default total-queue=default-small
    add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=both \
    disabled=no interface=all limit-at=1040k/1040k max-limit=1040k/1040k name=\
    videos packet-marks=youtube parent=none priority=8 queue=\
    hotspot-default/hotspot-default total-queue=default-small
    add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=both \
    disabled=no interface=all limit-at=1040k/1040k max-limit=1040k/1040k name=\
    users-video parent=videos priority=8 queue=hotspot-default/hotspot-default \
    total-queue=default-small


    ردحذف
  13. لو حد معاه ملف الاسكريبت علشان لما بنسخ الى فوق ده بينزل بشكل غريب على ملف التكست

    ردحذف
  14. مشكورررررررررررررررررر

    ردحذف

إذا أعجبك محتوى موقع ميكروتيك العرب اتمنى البقاء على تواصل دائم ، فقط قم بإدخال بريدك الإلكتروني للإشتراك في بريد المدونة السريع ليصلك جديد المدونة أولاً بأول ، كما يمكنك إرسال رساله بالضغط على الزر المجاور ...