الدخول على السيرفر ميكروتيك من الخارج بطريقة سهلة اوتوماتيكيا عبر noip&dnsomatic mikrotik



طرق كثيرة للدخول على السيرفر من الخارج

ودى احد الطرق

بدون الدخول على الايميل فقط هايبقى اسم بتدخل 

عليه بكل سهولة تدخل على الميكروتيك الخاص بك

الطريقة سهلة شرحها الاخ احمد السكران من موقع ويكى الميكروتيك

نشوف بالفيديو كيفية عمل الطريقة









وبتدخل عن طريق كتابة الدى ان اس نيم فى الوينبوكس سيرفر


 
/system script
add name=DNSoMatic policy=ftp,read,write,test,winbox,api source="# DNSoMatic a\
    utomatic DNS updates\r\
    \n\r\
    \n#--------------- Change Values in this section to match your setup -----\
    -------------\r\
    \n\r\
    \n# User account info of DNSoMatic\r\
    \n\r\
    \n:local maticuser \"user\"\r\
    \n:local maticpass \"pass\"\r\
    \n\r\
    \n# Set the hostname or label of network to be updated. This is the part a\
    fter the double colon (::) on the DNSoMatic services page.\r\
    \n# Hostnames with spaces are unsupported. Replace the value in the quotat\
    ions below with your host names.\r\
    \n# To specify multiple hosts, separate them with commas. \r\
    \n# Use \"all.dnsomatic.com\" for the matichost to update all items in dns\
    omatic with this IP.\r\
    \n\r\
    \n:local matichost \"host\"\r\
    \n\r\
    \n#-----------------------------------------------------------------------\
    -------------\r\
    \n\r\
    \n# No more changes need\r\
    \n\r\
    \n:global previousIP;\r\
    \n\r\
    \n:log info \"Fetching current IP\"\r\
    \n\r\
    \n# Get the current public IP using DNS-O-Matic service.\r\
    \n/tool fetch url=\"http://myip.dnsomatic.com/\" mode=http dst-path=mypubl\
    icip.txt\r\
    \n\r\
    \n# Read the current public IP into the currentIP variable.\r\
    \n:local currentIP [/file get mypublicip.txt contents]\r\
    \n\r\
    \n:log info \"Fetched current IP as \$currentIP\"\r\
    \n    \r\
    \n:if (\$currentIP != \$previousIP) do={\r\
    \n    :log info \"DNSoMatic: Update needed\"\r\
    \n    :set previousIP \$currentIP\r\
    \n    \r\
    \n# The update URL. Note the \"\\3F\" is hex for question mark (\?). Requi\
    red since \? is a special character in commands.\r\
    \n    :local url \"http://updates.dnsomatic.com/nic/update\\3Fmyip=\$curre\
    ntIP&wildcard=NOCHG&mx=NOCHG&backmx=NOCHG\"\r\
    \n    :local matichostarray;\r\
    \n    :set matichostarray [:toarray \$matichost];\r\
    \n    :foreach host in=\$matichostarray do={\r\
    \n        :log info \"DNSoMatic: Sending update for \$host\"\r\
    \n        /tool fetch url=(\$url . \"&hostname=\$host\") user=\$maticuser \
    password=\$maticpass mode=http dst-path=(\"dnsomaticupdate-\" . \$host . \
    \".txt\")\r\
    \n        :log info \"DNSoMatic: Host \$host updated on DNSoMatic with IP \
    \$currentIP\"\r\
    \n    }\r\
    \n}  else={\r\
    \n    :log info \"DNSoMatic: Previous IP \$previousIP and current IP equal\
    , no update need\"\r\
    \n}"
add name=ip policy=ftp,read,write,policy,test,winbox,api source=":global previ\
    ousIP;\r\
    \n:set previousIP \"\"\r\
    \n\r\
    \n:log info \"Cleared previousIP to force DNS-O-Matic update on next run.\
    \""

/system scheduler
add disabled=no interval=1m name=DNSoMatic1 on-event=DNSoMatic policy=\
    ftp,read,write,test,winbox,api start-date=nov/02/2014 start-time=11:38:18
add disabled=no interval=1m name=ip on-event=ip policy=\
    ftp,read,write,policy,test,winbox,api start-date=nov/02/2014 start-time=\

    11:53:41

تحياتى لكم

شادى سوفت


  1. كل كا اطلب ddns يخوش على الروتر مايخشش على السيرفر ايه الحل

    ردحذف
  2. السلام عليكم & انا بعمل الطريقه علي كيسه نسخه 5.21 الط ريقه شغاله تمام باجي اعمل نفس الخطوات علي روتر بورد نسخه 5.16 يتم قراءه الاسكربت في السريفر ولكن مفيش اي حاجه بتفتح من خارج الشبكه ياريت الي عنده حل يتفضل يقوله وشكرا لكم

    ردحذف
  3. السلام عليكم ...ممكن لو تكرمتم ملف txt الدخول على السيرفر ميكروتيك من الخارج بطريقة سهلة اوتوماتيكيا عبر noip&dnsomatic mikr

    ردحذف
  4. السلام عليكم ...ممكن لو تكرمتم ملف txt الدخول على السيرفر ميكروتيك من الخارج بطريقة سهلة اوتوماتيكيا عبر noip&dnsomatic mikr

    ردحذف
  5. السلام عليكم ...ممكن لو تكرمتم ملف txt الدخول على السيرفر ميكروتيك من الخارج بطريقة سهلة اوتوماتيكيا عبر noip&dnsomatic mikr

    ردحذف
  6. السلام عليكم ...ممكن لو تكرمتم ملف txt الدخول على السيرفر ميكروتيك من الخارج بطريقة سهلة اوتوماتيكيا عبر noip&dnsomatic mikr

    ردحذف
  7. السلام عليكم ...ممكن لو تكرمتم ملف txt الدخول على السيرفر ميكروتيك من الخارج بطريقة سهلة اوتوماتيكيا عبر noip&dnsomatic mikr

    ردحذف
  8. شكراااااااااااااااااااااااااااااا

    ردحذف
  9. كل ماكتب ddns يدخلنى على الروتر نوعه تي بي لينك مايخشش على السيرفر ايه الحل ممكن يا استاذ شادي الحل بعد ازنك

    ردحذف
  10. كل ماكتب ddns يدخلنى على الروتر نوعه تي بي لينك مايخشش على السيرفر ايه الحل
    او التعديل ايه

    ردحذف
  11. مشكور على المجهود

    ردحذف
  12. مشكور بش مهندس شادي انا عاوز اتكلم معك ياباشا ممكن رقم تلفونك او طريقة للتواصل مشكورر

    ردحذف

إذا أعجبك محتوى موقع ميكروتيك العرب اتمنى البقاء على تواصل دائم ، فقط قم بإدخال بريدك الإلكتروني للإشتراك في بريد المدونة السريع ليصلك جديد المدونة أولاً بأول ، كما يمكنك إرسال رساله بالضغط على الزر المجاور ...