مراقبة الخطوط وسحب الخطوط فى حالة الدمج على كارت لان واحد بكل سهولة تعرف كل خط بيعمل ايه؟ TEST SPEED ALL WAN



موضوع الدمج على كرات لان واحد هو موضوع الموسم وجبار بجد

لكن ناس كتير سالت ازاى اقدر اعرف كل خط واخد منه اد ايه؟..

واعرف الخط نفسه سحب اد ايه علشان حوار الاستخدام العادل؟

والنهاردة المهندس العملاق ابو جمجمة مشعشعة ومتكلفة وعالية اوى اوى

المهندس محمود ابو الدهب حقق لنا اللى عاوزين نعمله بكل سهولة

فعلا قدرت اراقب كل خط ساحب كام حالا دلوقتى

وقدرت احسب كل خط سحب كام ميجا وكام جيجا


وكمان بعت لى تعديل على اللى انتم شوفتوه بالفيديو بيحسب بالميجا بدلا من البايت

شوفوا الفيديو وانتم تفهموا احنا عملنا ايه بالظبط








والان تحميل الملف عدل فيه عدد كروتك براحتك وبيحسب بالميجا مش البايت
الملف بيحسب بالبايت حمل
 
الملف يحسب بالميجا حمل

مره واحده فقط
/ip firewall filter 
add action=passthrough chain=forward connection-mark=WAN1_conn comment="0" 
add action=passthrough chain=forward connection-mark=WAN2_conn comment="0"
add action=passthrough chain=forward connection-mark=WAN3_conn comment="0"
add action=passthrough chain=forward connection-mark=WAN4_conn comment="0"
add action=passthrough chain=forward connection-mark=WAN5_conn comment="0"


يوضع فى سكربت كل ربع ساعه

:global sp1 [/ip firewall filter get [find connection-mark="WAN1_conn"] byte]
:global sp2 [/ip firewall filter get [find connection-mark="WAN2_conn"] byte]
:global sp3 [/ip firewall filter get [find connection-mark="WAN3_conn"] byte]
:global sp4 [/ip firewall filter get [find connection-mark="WAN4_conn"] byte]
:global sp5 [/ip firewall filter get [find connection-mark="WAN5_conn"] byte]
:global ol1 ([/ip firewall filter get [find connection-mark="WAN1_conn"] comment] * 1048576)
:global ol2 ([/ip firewall filter get [find connection-mark="WAN2_conn"] comment] * 1048576)
:global ol3 ([/ip firewall filter get [find connection-mark="WAN3_conn"] comment] * 1048576)
:global ol4 ([/ip firewall filter get [find connection-mark="WAN4_conn"] comment] * 1048576)
:global ol5 ([/ip firewall filter get [find connection-mark="WAN5_conn"] comment] * 1048576)
:global all1 ($sp1 + $ol1)
:global all2 ($sp2 + $ol2)
:global all3 ($sp3 + $ol3)
:global all4 ($sp4 + $ol4)
:global all5 ($sp5 + $ol5)
/ip firewall filter set [find connection-mark="WAN1_conn"] comment=( $all1 /1048567)
/ip firewall filter set [find connection-mark="WAN2_conn"] comment=( $all2 /1048567)
/ip firewall filter set [find connection-mark="WAN3_conn"] comment=( $all3 /1048567)
/ip firewall filter set [find connection-mark="WAN4_conn"] comment=( $all4 /1048567)
/ip firewall filter set [find connection-mark="WAN5_conn"] comment=( $all5 /1048567)
/ip firewall filter reset-counters-all

تحياتى لكم شادى سوفت

pass mikrotikarabic.blogspot.com


  1. تسلم .. جزاك الله خيرا

    ردحذف
  2. بارك الله فيك و المهندس الي بعتلك السكربت جزاكم الله خيرا

    ردحذف
  3. مشكور كثير اخ شادي ولكن انا عندي ملاحظة واود منك ان تفيدنا فيه ازا استطعت انشاء الله
    احنا كشبكات لاسلكية بنعاني انو في اغلب الأوقات واغلب الأيام بكون السحب كبير على اليوتيوب
    احنا عاوزين طريقة نحدد حجم ملف الفيديو سواء عن طريق زمن الفيديو او عن طريق حجمه بحيث عندما اود مشاهدة الفيديو على اليوتيوب ما يفتح معي ولا اي فيديو خارج نطاق الحجم المحدد له وخصوصا في وقت الذروة حيث ان اغلب الناس بتحب تشاهد المسرحيات والأفلام وهذا يرهقنا كقيرا فأرجو من فضلكم مساعدتنا

    ردحذف
  4. أزال المؤلف هذا التعليق.

    ردحذف
  5. اخ شادي انا بحترمك كثير كثير بس عندي تعليق صغير
    بخصوص سياسة الإستخدام العادل ومشاكل اليوتيوب وغيرها من مواقع الأفلام الي بترهق الشبكة وبتخليها مثل الزفت وكمان بتدخلك ضمن سياسة الإستخدام العادل
    انا عندي تنويه صغير
    بدل ما نعمل سكربتات ورولات كثيرة عشان نحصل على شيء يساعدنا وطبعا على حساب المشترك , ليش ما نفكر بإنو نعمل سيرفر سكويد يعمل حفظ لكافة مقاطع الأفلام التي يتم مشاهدتها
    بحيث انه لما يجي اي مشترك ويتفرج على فيديو على اليوتيوب وبمحض الصدفة يكون مخزن في كاش السكويد بدل ما ياخدو من الراوتر ياخدو من سيرفر السكويد ويتفرج عليه بسرعة كبيرة
    انا عن نفسي عامل سيرفر سكويد على اوبنتو 14.4 وبيعمل تخزين لكافة مقاطع الأفلام وكمان الصفحات وملفات الأغاني وكل حاجة ومريح حالي من سياسة الإستخدام العادل الي مقرفه الشبكات

    دائما وابدا يا اخ شادي لما تلاقي حالك في مشكلة مثل سياسة الإستخدام العادل دور كيف تطور حالك بحيث تكون اكبر من هاي المشكلة واقوى منها مش نتعامل مع المشكلة ونتأقلم معها ويكون على حساب المشترك ..... وشكرا ,,,, اما بخصوص سيرفر السكويد ازا حبيت اعطيك الرولات الي بشتغل عليها ما عندي مانع بس راسلني بالأول

    ردحذف
  6. تسلم يا كبير والى عمل الاسكربت يبنا يزيدك علم كمان وكمان

    ردحذف
  7. نسخ الرول افضل من التحميل الف شكر لك

    ردحذف

إذا أعجبك محتوى موقع ميكروتيك العرب اتمنى البقاء على تواصل دائم ، فقط قم بإدخال بريدك الإلكتروني للإشتراك في بريد المدونة السريع ليصلك جديد المدونة أولاً بأول ، كما يمكنك إرسال رساله بالضغط على الزر المجاور ...